Which hosting provider worked for you?

Coordinator
Jan 13, 2008 at 3:20 PM
ModPack for BE.NET 1.3.0.5 works out of the box on GoDaddy (Deluxe) accounts.

If you tried this release for your provider ....
Would you please share your experiences?

Thanks!
Mike
Jan 19, 2008 at 1:04 AM
Greetings,
Tried it, but it did NOT work. My Webhost is Webhost4life.com and here is what I did.
(1)Downloaded.
(2) Unzipped to a folder
So here is what I have: http:\\www.mysite.com\blogenginemodFolder
So I browsed to http:\\www.mysite.com\blogengineFolder\default.aspx.
Then I get the Error,
Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.
Coordinator
Jan 19, 2008 at 2:57 AM
Edited Jan 19, 2008 at 2:58 AM
Greetings yousaid,

Sorry to hear your first attempt on WebHost4Life didn't work out.

Your pasted error message might indicate the following:

The folder you used hasn't been configured as IIS application yet.

Please try the following (taken from WebHost4Life support)

[...] the (sub)folder that contains the BIN folder must be turned to a web application (you can use the tool called "Set IIS Application" from hosting control panel) but NOT the bin folder itself.

In other words: use your hosting control panel to set the ModPack folder as “IIS Application”.

Could you please let me know if that worked out for you?

Thank you and also for trying ModPack on WebHost4Life!

Cheers,
Mike

BTW: great you're using this forum too. I also replied on the demo site comment and forwarded by email. Let's continue our talk on here if that's ok with you?
Coordinator
Jan 23, 2008 at 11:53 AM
Hi there,

Does your blog on WebHost4Life work now after using their control panel?

Cheers Mike
Mar 3, 2008 at 3:54 AM
Edited Mar 3, 2008 at 4:11 AM
Hosted on 1and1.

So far, haven't gotten it to work.

Note: I have NOT activated MS FrontPage Server Extensions. Is this applicable? Sorry if it's a dumb question... I've done web application development/programming, but web page dev/et al is a much different animal.

Unzipped to blog/; set blog/ as an application; set permissions on blog/App_Data -- read/write for Network Service, and the same for IUSER (Internet User, just set this trying to get it to work).

When I access me.com/blog/, I get a blank page.
When i hit blog.me.com (registered subdomain), I get:
Server Error in '/' Application.
The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been
removed, had its name changed, or is temporarily unavailable. Please review the following URL and
make sure that it is spelled correctly.

Requested URL: /default.aspx

Mike, you work on this mod is appreciated. Hopefully we can conquer the beast that is 1and1.

Jeff C
Coordinator
Mar 3, 2008 at 9:44 AM
Hi Jeff,

Installing ModPack into a physical folder 'blog' results in errors on every hosting provider, including 1and1. That's a known issue and caused by my change in URL rewriting/redirecting. By default, BE.NET uses a virtual page '~/blog.aspx' to show the 'blog post view'. I wanted a folder instead, so I rewrote that to use a virtual folder redirect '~/blog/'. Works unless your physical folder already uses 'blog' too. So:

Could you install ModPack into any folder other than 'blog' in your 1and1 account? (e.g. in the absolute web root, '/jeff/' or '/whatever/')

Then we'll see what happens in that scenario and hopefully conquer the beast in its own lair ;-)

ModPack should work though when the word 'blog' is in your subdomain.
Do not activate MS Frontpage Server Extensions, it's not required and usually causes problems anyway.

Thank you Jeff for trying ModPack on 1and1, I've heard one story from a blogger who got it working there right after he removed 'blog' in the folder path.

If you're still experiencing issues then, we'll dive into other troubleshooting options, ok?

Cheers Mike (and I believe there's no such thing as dumb/stupid questions)
Mar 5, 2008 at 4:20 AM
Thanks, Mike.

Ok, seemingly to no avail, ModPack is now in me.com/b/, which has been set as an application.

Same results as above hitting me.com/b/ or blog.me.com.

I haven't touched web.config -- I know some blog installations require modifying this before putting it on the server. Since I've not seen that mentioned here or in other BlogEngine docs, I assume it's part of the setup process?

Note that I have a multiple-domain account w/ 1and1, so I have to specifically designate a directory for each domain to keep them from pulling from the root. I've set the 'web space' for me.com to "/me", and for blog.me.com to "/me/b" (this may be typical hosting practice, but I mention it just in case).

For the record, as an Instructor (former life, currently farming) for everything from Marines to scientists to professionals from many walks of life, I have to disagree -- I've been asked (and have asked) many dumb questions. The Wise knows the question is stupid, and asks it. The Fool stays quiet.

Ok, back to the task at hand -- anything you need from me, just ask. My response time may be a little slow because my wife's taking 18 hours of e-learning, and we have 6 kids, one of which is 1 yr... so I'm a little distracted in the evenings. And, unlike when I was developing/instructing, with farming I gotta get at least 6 hours sleep a night... sucks. I hate sleep, the bane of my existence.

Jeff C
Coordinator
Mar 7, 2008 at 3:57 PM
Hi Jeff,

So the issue in short: as subdomain = 404 error and as subfolder = blank page, right?

Which Internet browsers did you test? (both IE as Firefox?)
Have you tried disabling the compress and CSS-trim option in BE.NET's configuration panel?
Could you share the actual address of your site? (or just email it to me if you like to keep it private)

Thanks Mike
Mar 8, 2008 at 12:24 AM
Sorry, Mike -- Actually, I'm getting the 404 error for both subdomain and subfolder of domain.

Getting the errors both on IE and Firefox (latest updates for each).

You've lost me regarding BE.NET's configuration panel. Is this a file accessible via the web, or changes I'm to make on local? Sorry, no clue here.

I've sent my domain. Please holler if you need anything more, or to explain the config panel issue.

Thanks.
Jeff C
Coordinator
Mar 8, 2008 at 1:13 AM
Edited Mar 8, 2008 at 1:15 AM
Hi Jeff,

Just replied to you by email too. Thank you for sending me more details and as I wrote, it seems like some domain parking feature is enabled on your site. It might cause the issue you're experiencing.

As for the BE.NET configuration panel, I'm sorry for losing you there and never mind this suggestion, because:

This panel you'll see if you login with your admin username and password on your BE.NET/ModPack blog site. But apparently you're only seeing a blank page or 404 error. So let's focus first to see if this domain parking thing is causing you the trouble and then we'll dig deeper.

Thank you for your forum message and your email with more details. I highly appreciate your personal note.

Cheers Mike
Mar 8, 2008 at 4:38 AM
Mike

It was 'Blank Page Parking' -- a 'helpful' little feature that is supposed to display content 'applicable to your domain name' instead of a 404 page. Apparently it's enabled by default, and couldn't find applicable content.

I've turned of that feature, and now, hitting as subdomain or by directory, am getting the Server Error in '/' Application ... resource cannot be found ... 404 error.

I've restarted the Application on /b/, verified permissions.

I also pulled the subdomain for now to take it out of the mix -- didn't help, but I'll wait until something's figured out before setting it back.

Thanks, Mike. Again, whatever you need.

Jeff C
Coordinator
Mar 8, 2008 at 11:15 AM
Edited Mar 8, 2008 at 11:16 AM
Jeff,

Starting to make sense here. You need to edit your web.config file for letting BE.NET know which path is used for your blog.

The line is: <add key="BlogEngine.VirtualPath" value="~/" />

Your web.config value depends on where you run your blog. In your case the value then is:

<add key="BlogEngine.VirtualPath" value="~/b/" />

(note that ModPack by default just use "/" without the tilde/~ character to 'force' the application simulate running in the web root of your web site)

You're welcome Jeff and once you've determined the final setup of your blog (like the address, subdomain or subfolder, etc) we hopefully can move forwards.

Does changing the above line for your web.config now work though?
Mike
Mar 9, 2008 at 4:00 AM
Mike,

Made the changes, but getting the same error. Because of the directory structure for my account with 1and1 (root/mydomain/b), I tried both

<add key="BlogEngine.VirtualPath" value="~/b/" />
and
<add key="BlogEngine.VirtualPath" value="~/me8/b/" />

Jeff C
Coordinator
Mar 9, 2008 at 9:12 AM
Thank you Jeff for baring the unfruitful troubleshooting attempts. The only suggestion I've probably left is for you to leave out that tilde (~) character. That's what broke many stuff on GoDaddy accounts. So in your case the web.config value would be:

<add key="BlogEngine.VirtualPath" value="/b/" /> (if your site is www.YourDomain.com/b/)

If this is still not working, I'd really need to see screenshots of your whole directory structure and files, like the web.config files in every folder and subfolder. I'm very willing to help you as much as I can. It just seems to be a pretty hard case here and wishing I knew why.

Mike
Mar 10, 2008 at 4:57 AM
Tried with the tilde removed, same results.

I've sent the information you requested via the contact form on your site. Let me know if you need more.

Thanks for your time and patience!

Jeff C
May 1, 2008 at 4:24 AM
Just wanted to thank you MikevZ for all the work you've done on the Modpack.

I have a Deluxe account on GoDaddy, but I could not for the life of me figure out how to get this to work. My problem was that I was trying to get it to work locally using Visual Web Designer. I spent many, many, hours searching online for the answer. I finally stumbled onto this page and realized that I needed to change the BlogEngine.VirtualPath value, rename the subfolder to something other than "blog", and just put the thing online instead of trying to run it locally. After doing that it just worked. IT WORKED!

One suggestion would be to put that information (especially the "blog" subfolder tip) on the main Modpack page under the instructions. Also, it might be useful to other people to know that Visual Web Designer doesn't like BlogEngine.Net in a subfolder.

Thanks again, and know that your efforts have not gone unnoticed. You've made me week. : )
Coordinator
May 3, 2008 at 1:00 PM
Hi jzierse, thanks for your kind note and useful feedback!

You wrote:
Just wanted to thank you MikevZ for all the work you've done on the Modpack.

I have a Deluxe account on GoDaddy, but I could not for the life of me figure out how to get this to work. My problem was that I was trying to get it to work locally using Visual Web Designer. I spent many, many, hours searching online for the answer. I finally stumbled onto this page and realized that I needed to change the BlogEngine.VirtualPath value, rename the subfolder to something other than "blog", and just put the thing online instead of trying to run it locally. After doing that it just worked. IT WORKED!

One suggestion would be to put that information (especially the "blog" subfolder tip) on the main Modpack page under the instructions. Also, it might be useful to other people to know that Visual Web Designer doesn't like BlogEngine.Net in a subfolder.

Thanks again, and know that your efforts have not gone unnoticed. You've made me week. : )


BTW: ModPack 1.3.0 Service Release 1 should work in any installed subfolder now, including "blog" - tested it last week in my own account.
Could you please verify you're running MP130SR1 and see if it works?

Cheers,
Mike
Coordinator
May 3, 2008 at 1:03 PM
1&1 Hosting users in struggle ... check this out:

This BlogEngine.NET user on 1and1 posted a step-by-step solution - here's a copy of his steps (which I slightly edited):
  1. Create a subfolder in your web space where you want your blog to go
  2. Point your domain (in the 1and1 domains tab) to the root (/) of your web space - that's the strange part, see the redirect script
  3. Create your application (basically the same as your asp.net application in IIS) on this subfolder
  4. Set write access to the Network Service and IUSRx user on the AppData folder
  5. Create this default.asp file in the root of your webspace which looks like this:

<%EnableSessionState=False
host = Request.ServerVariables("HTTP_HOST")
if host = "YourDomain.com" or host = "www.YourDomain.com" then
response.redirect("http://YourDomain.com/SubFolderAsInStep1/default.aspx")
elseif host = "example.com" or host = "www.example.com" then
response.redirect("http://example.com/SomeFolder/default.aspx")
else
response.redirect("http://YourDomain.com/error.htm")
end if
%>

Hope 1&1 customers can now (finally!) use our beloved blog platform.

Cheers,
Mike
Jan 21, 2009 at 8:49 PM
Hi,

I posted a message in the other area, and it was suggested that I repost over here.  So, I'm sorry if I offend anyone by double posting.  

I'm hoping someone can help me out. My wife wants a Blog and I'm trying to get BlogEngine.NET working on 1&1. I've searched pretty much all the sites on using BlogEngine and 1&1 and understand that some have it working while others have given up. Since I'm not the type to give up and I know others have it working I'm hoping someone will be able to make my life much easier with my wife! :)

Listed below is the error message that I'm getting currently... (The text blow, contained within the ==='s show the text from my web browser.)

What I have done and how I'm set up.

I have a couple of different websites hosted from this one account. I've read that I need to redirect from the default.aspx page to the directory that I have BlogEngine installed. BlogEngine.NET is installed in a directory 'blogengine' off the root. When someone enters 'www.cashinonrepair.com', the default.aspx, which is located in the root, will redirect them to blogengine's default.aspx in the 'blogengine' directory.

I have also set the 'blogengine' directory as an ASP application via 1&1's web interface. I have also set the folder '\blogengine\app_data' to full read/write permissions for the two users listed on my access rights page.

Any guidance would be greatly appreciated. I'm using ModPack version 1.4.5 of BlogEngine.NET

Does ModPac require .net 3.5?  That was the question the other kind individual posted in the other forum.

Sincerely,
Brian

==========================================================================================================================
Server Error in '/BlogEngine' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.

Source Error:


Line 55: <add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
Line 56: <add assembly="System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
Line 57: <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
Line 58: <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
Line 59: <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>


Source File: E:\kunden\homepages\30\d230996570\blogengine\web.config Line: 57

Assembly Load Trace: The following information can be helpful to determine why the assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' could not be loaded.


WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].




--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433
===========================================================================================================================
Oct 22, 2010 at 4:07 PM
Edited Oct 22, 2010 at 4:21 PM

Hello, I know this post is a little old now but I seem to be having problems I have followed the steps but now seem to be getting a different error...

http://www.quickslip.co.uk/

Would really appreciate some help I must be missing something....

Cheers

 

Update!! maybe I was a little rushed seems to be working now! But my theme wont load I can see it on preview but not on the live page...  :(

Oct 22, 2010 at 8:01 PM
Edited Oct 22, 2010 at 8:46 PM

Sadly I thought I may have been half way there but I cant add posts i just get this error and i can delete anything either... Really hope someone out there has some help for me

cheers

 

Server Error in '/blog' Application.

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 

Requested URL: /blog/post/test.aspx


 

 

Version Information: Microsoft .NET Framework Version:2.0.50727.3615; ASP.NET Version:2.0.50727.3614